注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

郁夫的博客

我爱你们,只是你们不知道!

 
 
 

日志

 
 
 
 

Phonegap 开发 Android 应用的环境搭建  

2014-07-29 15:53:59|  分类: android |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
首先需要安装 node.js , 其有windows的安装包,很容易。
最开始先直接安装 phonegap
npm install -g phonegap
结果出现很多问题,首先要设置好Java 目录,window 环境变量中
 JAVA_HOME = C:\Program Files\Java\jdk1.7.0_25
安装 ant ,设置 ant 环境变量
ANT_HOME = D:\ant194
CLASSPATH = %ANT_HOME%\lib
path 中加入 %ANT_HOME%\bin;
设置 android  环境变量
ANDROID_HOME = D:\adteclipse\sdk
path 中加入 %ANDROID_HOME%\tools;%ANDROID_HOME%\platform-tools 
结果 phonegap create myapp   创建项目后
phonegap serve一直不能运行。安装cordova 
npm install -g cordova ,安装随成功但提示有文件版本不符。
后卸载 phonegap 和 cordova,重新先安装 cordova,再安装phonegap。
安装过程很顺利,phonegap serve 可以运行。
然后可以通过android 上 phonegap 软件直接看到app 的页面。
  评论这张
 
阅读(199)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017